XML/XHTML/HTML Support?

Jan 5, 2011 at 4:09 AM

I've been successful in getting this installed on my blog.  I'm referencing the files just like you do on your blog.  When I added a code sample that was marked as XML/HTML, I keep getting an error.

Here's my code reference:

<link href='http://alexgorbatchev.com/pub/sh/current/styles/shThemeDefault.css' rel='stylesheet' type='text/css'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shCore.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shAutoloader.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shBrushJScript.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shBrushPowerShell.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shBrushCss.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shBrushCSharp.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shBrushSql.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shBrushVb.js' type='text/javascript'/>
<script src='http://alexgorbatchev.com/pub/sh/current/scripts/shBrushXml.js' type='text/javascript'/>

The error I keep getting is: 
SyntaxHighlighter
Brush wasn't configured for html-script option: xhtml
The code that is added by Syntax4writer is:
<pre class="brush: xhtml; toolbar: false">

What do you think is causing the issue?

Coordinator
Jan 7, 2011 at 1:34 PM

hi,

As you could see on the blog post http://www.tugberkugurlu.com/41 you need to add the following script code after your script refernces;

<script type="text/javascript">     

SyntaxHighlighter.all(); 

</script>

Give it a shot.